Users not receiving emails
Incident Report for Frame.io
Resolved
This incident has been resolved.
Posted over 1 year ago. Mar 13, 2018 - 08:03 EDT
Investigating
We are currently investigating issues with emails not being received by users, we apologize for the inconvenience and thank you for your patience while we work on this.
Posted over 1 year ago. Mar 13, 2018 - 07:36 EDT