Presentation pages intermittently inaccessible
Incident Report for Frame.io
Resolved
This incident has been resolved.
Posted 3 months ago. Apr 19, 2017 - 20:06 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted 3 months ago. Apr 19, 2017 - 19:59 EDT
Investigating
We are currently investigating this issue.
Posted 3 months ago. Apr 19, 2017 - 19:40 EDT